about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-27T00·31+0300
committertazjin <tazjin@tvl.su>2022-09-04T17·40+0000
commit33cde1422e473770ab0ca30759ece618cb4c3680 (patch)
tree163268a01d64d0154339354a863cd18412f4f053 /tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix
parent10b0879c009098d3c5f9fe21067ff656a29442a5 (diff)
feat(tvix/eval): implement upvalue resolution in `with` scopes r/4635
These need to be handled specially by the runtime if the compiler
determines that a given local must be resolved via `with`.

Note that this implementation has a bug: It currently allows `with`
inside of nested lambdas to shadow statically known identifiers. This
will be cleaned up in the next commit.

Change-Id: If196b99cbd1a0f2dbb4a40a0e88cdb09a009c6b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6299
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix
new file mode 100644
index 0000000000..7e2f7c073b
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-with-closure.nix
@@ -0,0 +1,5 @@
+# Upvalues from `with` require special runtime handling. Do they work?
+let
+  f = with { a = 15; }; n: n * a;
+in
+f 10