about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-10T18·48-0400
committergrfn <grfn@gws.fyi>2022-10-11T00·33+0000
commit4283f0139a82299c5240a25bb27ae84be3c99e13 (patch)
tree259c27f7bc5bc86f77d042b9b639c648210cf5d7 /tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix
parent562c50fadd5e439eeed4039eb9dc119b07fe8722 (diff)
feat(tvix/eval): Implement builtins.removeAttrs r/5102
Change-Id: I28910991a0108436a42ac7bf3458f9180a44154e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6928
Reviewed-by: Adam Joseph <adam@westernsemico.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix
new file mode 100644
index 0000000000..4ad5ba897f
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-remove.nix
@@ -0,0 +1,5 @@
+let {
+  attrs = {x = 123; y = 456;};
+
+  body = (removeAttrs attrs ["x"]).y;
+}
\ No newline at end of file