about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-09-18T19·34-0400
committerclbot <clbot@tvl.fyi>2022-09-18T22·08+0000
commit6f70f325138b48f2c9b03a2103371663cb210d7c (patch)
treea5eeb3b027a98e387c2cc24a8999bc60f376c241 /tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix
parent0b76ed5615eb48130773abf1e1a949e29b6cbd25 (diff)
fix(tvix/eval): Force thunks during equality comparison r/4910
Thunks might be encountered deep in equality comparison (eg nested
inside a list or attr-set), at which point we need to force them in
order to compare them for equality (or else we panic when trying to get
at their value).

Fixes: b/192
Change-Id: I912151085f8298f30d5214c7965251c9266443f2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6652
Autosubmit: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix
new file mode 100644
index 0000000000..b0ec8593a4
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-lazy-equality.nix
@@ -0,0 +1,11 @@
+let
+  attrs1 = { x = 1 + 2; };
+  attrs2 = { x = 2 + 1; };
+  list1 = [ (1 + 2) ];
+  list2 = [ (2 + 1) ];
+  list3 = [ (2 + 2) ];
+in [
+  (attrs1 == attrs2)
+  (list1 == list2)
+  (list3 == list2)
+]