about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-xml.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-23T13·34+0200
committerclbot <clbot@tvl.fyi>2024-01-25T11·37+0000
commit023e372583b7bcc71b5c301c49501cc72204068f (patch)
tree6ea7a216292fb4db2154285371535b714fff498d /tvix/eval/src/tests/nix_tests/eval-okay-xml.nix
parente1d25891638597b0085033fd99814fce83fab4b9 (diff)
feat(tvix/eval): track pattern binding names r/7448
These need to be preserved at least for builtins.toXML.

Also, we incorrectly only wrote an <attrspat> in case ellipsis was true,
but that's not the case.

Change-Id: I6bff9c47c2922f878d5c43e48280cda9c9ddb692
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10686
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: aspen <root@gws.fyi>
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/eval-okay-xml.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-xml.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/nix_tests/eval-okay-xml.nix b/tvix/eval/src/tests/nix_tests/eval-okay-xml.nix
new file mode 100644
index 0000000000..9ee9f8a0b4
--- /dev/null
+++ b/tvix/eval/src/tests/nix_tests/eval-okay-xml.nix
@@ -0,0 +1,21 @@
+rec {
+
+  x = 123;
+
+  y = 567.890;
+
+  a = "foo";
+
+  b = "bar";
+
+  c = "foo" + "bar";
+
+  f = {z, x, y}: if y then x else z;
+
+  id = x: x;
+
+  at = args@{x, y, z}: x;
+
+  ellipsis = {x, y, z, ...}: x;
+
+}