about summary refs log tree commit diff
path: root/tvix/eval/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-09-04T17·09+0200
committerclbot <clbot@tvl.fyi>2022-09-04T21·02+0000
commitb0d39aa19f180ad6cab634d11d4e51a0d3bd7710 (patch)
treeb0a97d6717e9ddd65dbd8075311b38fe38aadb1f /tvix/eval/default.nix
parent01a0d5c82205c0b0677af0f8c60ad5e9ba23ce02 (diff)
fix(tvix/eval): don't rebuild drv upon changes in cargo target dir r/4646
This avoids unnecessary rebuilds of //tvix/eval when working on it
locally using impure cargo.

Change-Id: I028033a6345a9655e2877a534448706b8f85a1a1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6317
Tested-by: BuildkiteCI
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/eval/default.nix')
-rw-r--r--tvix/eval/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tvix/eval/default.nix b/tvix/eval/default.nix
index ea049eb492..a3b4a01ee0 100644
--- a/tvix/eval/default.nix
+++ b/tvix/eval/default.nix
@@ -2,7 +2,10 @@
 
 lib.fix (self:
 depot.third_party.naersk.buildPackage {
-  src = ./.;
+  src = depot.third_party.gitignoreSource ./.;
+  # see https://github.com/nix-community/naersk/issues/169
+  root = depot.nix.sparseTree ./. [ ./Cargo.lock ./Cargo.toml ];
+
   doCheck = true;
   cargoBuildOptions = opts: opts ++ [ "--all-targets" ];