about summary refs log tree commit diff
path: root/tvix/eval/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-11-05T23·50-0400
committergrfn <grfn@gws.fyi>2022-11-08T13·42+0000
commit645d0c06e541b57cf1b87877856f592c6fbf49ee (patch)
tree80aaa76e2e724fabc5b7614bb03735b7d41dd0d2 /tvix/eval/default.nix
parentcf82a545eb68b57ceb940ebd467e669ca19d7483 (diff)
feat(tvix/eval): Add a proc-macro for defining builtins r/5263
Add a single new proc macro to a new proc-macro crate,
`tvix-eval-proc-macros` for defining an inline module containing nix
builtins, and automatically generating a function within that module
which returns a list of those builtins as `tvix_eval::value::Builtin`.

Change-Id: Ie4afae438914d2af93d15637151a49b4c68aa352
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7198
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: Adam Joseph <adam@westernsemico.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/default.nix')
-rw-r--r--tvix/eval/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/eval/default.nix b/tvix/eval/default.nix
index d8e180b7cf..42722e5660 100644
--- a/tvix/eval/default.nix
+++ b/tvix/eval/default.nix
@@ -13,6 +13,10 @@ lib.fix (self: depot.third_party.naersk.buildPackage (lib.fix (naerskArgs: {
 
   meta.ci.targets = builtins.attrNames self.passthru;
 
+  copySources = [
+    "builtin-macros"
+  ];
+
   passthru.benchmarks = depot.third_party.naersk.buildPackage (naerskArgs // {
     name = "tvix-eval-benchmarks";