about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-06T13·31+0300
committertazjin <tazjin@tvl.su>2022-12-06T18·29+0000
commitf282984c25696dfbedc3ca2df9e44ca89b88b268 (patch)
tree2a65327af6842709eaedec84e5e591c59d211ea7 /tvix/eval/Cargo.toml
parent17e0a74e7b8eda6cdaeb0a6240738eb32356fcb1 (diff)
fix(tvix/eval): use rnix-parser from crates.io r/5396
A few weeks ago, oberblastmeister did a release to crates.io so we can
stop importing it via GitHub.

Change-Id: I9d5fa5cd281685779c71b12fed45ed201a1db17e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7532
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml7
1 files changed, 1 insertions, 6 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 1d42b793d3..e0c452ed58 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -29,12 +29,7 @@ serde_json = "1.0"
 regex = "1.6.0"
 builtin-macros = { path = "./builtin-macros", package = "tvix-eval-builtin-macros" }
 backtrace-on-stack-overflow = { version = "0.2.0", optional = true }
-
-# rnix has not been released in a while (as of 2022-09-23), we will
-# use it from git.
-[dependencies.rnix]
-git = "https://github.com/nix-community/rnix-parser.git"
-rev = "85a045afd33e073a3eab4c0ea2f515b6bed557ab"
+rnix = "0.11.0"
 
 [dev-dependencies]
 criterion = "0.3.6"