about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-09-22T21·31+0300
committertazjin <tazjin@tvl.su>2022-09-22T23·07+0000
commitc46025d52011632b9e53bc96cc115c1d74bfbf7a (patch)
tree7eb87f25117964deec072223cf39c6d85d880799 /tvix/eval/Cargo.toml
parentee0b89c4029fe027174018c14dcf7fcff342c8bf (diff)
fix(tvix/eval): support string identifiers in inherits r/4958
This updates rnix-parser to a version where inherits provide an
iterator over `ast::Attr` instead of `ast::Ident`, which mirrors the
behaviour of Nix (inherits can have (statically known) strings as
their identifiers).

This actually required some fairly significant code reshuffling in the
compiler, as there was an implicit assumption in many places that we
would have an `ast::Ident` node available when dealing with variable
access (which is then explicitly only not true in this case).

Change-Id: I12f1e786c0030c85107b1aa409bd49adb5465546
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6747
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index b23fc057ad..2edeccb9d1 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -25,11 +25,11 @@ proptest = { version = "1.0.0", default_features = false, features = ["std", "al
 test-strategy = { version = "0.2.1", optional = true }
 clap = { version = "3.2.22", optional = true, features = ["derive", "env"] }
 
-# rnix has not been released in a while (as of 2022-09-18), we will
+# rnix has not been released in a while (as of 2022-09-23), we will
 # use it from git.
 [dependencies.rnix]
 git = "https://github.com/nix-community/rnix-parser.git"
-rev = "7d0d929c22ad27bdcc0779afe445b541d3ce9631"
+rev = "85a045afd33e073a3eab4c0ea2f515b6bed557ab"
 
 [dev-dependencies]
 criterion = "0.3.6"