about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorRyan Lahfa <tvl@lahfa.xyz>2024-01-14T15·31+0100
committerraitobezarius <tvl@lahfa.xyz>2024-01-17T07·34+0000
commitbc8fb825c7e1e933e2b1ace21c305433e0c57522 (patch)
tree40eae4a30b2d818f609d6aafa0d9e123ef39fda0 /tvix/eval/Cargo.toml
parent850a4bfc7b93a802518128755bdbb4aa7a5eed9c (diff)
feat(tvix/eval): move away from `test_generator` to `rstest` r/7398
`test-generator` has not been updated in the past 2 years.
`rstest` has not been updated in the past 5 months.

This is an improvement in the maintenance state… I guess?
We get also new features, it changes the name of the tests with numbers too.

Change-Id: I5376104c7704f525dba7524da78daa09867cc669
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10623
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml7
1 files changed, 1 insertions, 6 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 2c8bb206ac..d1bb48a7c5 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -35,14 +35,9 @@ xml-rs = "0.8.4"
 criterion = "0.5"
 itertools = "0.12.0"
 pretty_assertions = "1.2.1"
+rstest = "0.18.2"
 tempfile = "3.3.0"
 
-[dev-dependencies.test-generator]
-# This fork of test-generator adds support for cargo workspaces, see
-# also https://github.com/frehberg/test-generator/pull/14
-git = "https://github.com/JamesGuthrie/test-generator.git"
-rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
-
 [features]
 default = ["impure", "arbitrary", "nix_tests"]