about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-03-11T22·39+0300
committertazjin <tazjin@tvl.su>2023-03-13T20·30+0000
commitb3f8d66a6acc4428cb963edda9db20c624dcebdd (patch)
tree5f4c9520a77ee6d753a1dcdfc4fbf7654071c276 /tvix/eval/Cargo.toml
parent94513525b939a13fb19330fe74dd9f6860a854fe (diff)
chore(tvix/eval): prune some dependencies & features r/5988
* We no longer need backtrace-on-stack-overflow, as we no longer
  overflow the stack with the recent eval refactorings. This was weird
  voodoo anyways, introduced earlier to debug some cases where stack
  overflows occured.

* default features of genawaiter crate are not needed, as we don't use
  their proc macros

Change-Id: I346fc5a18d7f117ee805909a8be8f535b96be76c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8263
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml8
1 files changed, 2 insertions, 6 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 6bb68834ab..e59249f1e7 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -9,12 +9,11 @@ edition = "2021"
 name = "tvix_eval"
 
 [dependencies]
-backtrace-on-stack-overflow = { version = "0.2.0", optional = true }
 builtin-macros = { path = "./builtin-macros", package = "tvix-eval-builtin-macros" }
 codemap = "0.1.3"
 codemap-diagnostic = "0.1.1"
 dirs = "4.0.0"
-genawaiter = "0.99.1"
+genawaiter = { version = "0.99.1", default_features = false }
 imbl = { version = "2.0", features = [ "serde" ] }
 lazy_static = "1.4.0"
 lexical-core = { version = "0.8.5", features = ["format", "parse-floats"] }
@@ -44,7 +43,7 @@ git = "https://github.com/JamesGuthrie/test-generator.git"
 rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
 
 [features]
-default = ["impure", "arbitrary", "nix_tests", "backtrace_overflow"]
+default = ["impure", "arbitrary", "nix_tests"]
 
 # Enables running the Nix language test suite from the original C++
 # Nix implementation (at version 2.3) against Tvix.
@@ -56,9 +55,6 @@ impure = []
 # Enables Arbitrary impls for internal types (required to run tests)
 arbitrary = ["proptest", "test-strategy", "imbl/proptest"]
 
-# For debugging use only; not appropriate for production use.
-backtrace_overflow = ["backtrace-on-stack-overflow"]
-
 [[bench]]
 name = "eval"
 harness = false