about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-30T16·53+0300
committertazjin <tazjin@tvl.su>2022-09-07T15·25+0000
commit727845645d4b6032e6b16dcfa997e14da9806084 (patch)
tree86c7560e9dcf01f1f0bac54882bab0dbbb5f3503 /tvix/eval/Cargo.toml
parent79a2ba51752da188323ecf53d7b55fc5bedc003a (diff)
chore(tvix/eval): add release-with-debug cargo profile r/4698
This lets us create a release build with debug info, for use with e.g.
perf + hotspot

Change-Id: I03897de36c872d318abf1332ca0c1aeabe344ec6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6362
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 32fa9e2573..dc5d10c8e8 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -36,3 +36,7 @@ disassembler = ["dep:tabwriter"]
 [[bench]]
 name = "eval"
 harness = false
+
+[profile.release-with-debug]
+inherits = "release"
+debug = true