about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-09-01T12·52+0300
committertazjin <tazjin@tvl.su>2022-09-07T19·08+0000
commit39e960daa67d3cebb033f0490e570dbbcd9dffa0 (patch)
tree4bfc1a6c4b3981add15df151800d6eeba2d798ad /tvix/eval/Cargo.toml
parentf8919dbcd6137f1d4656827e1b3cefe58cee119b (diff)
chore(tvix/eval): add codemap dependency r/4707
This will be used to track source spans when emitting bytecode.

The codemap is a data structure which tracks *all* the source files
visited by an evaluation, and makes it possible to represent locations
across all of the files using a simple span (i.e. pair of offsets).

When reporting errors, this even contains enough information to
reconstruct the rnix AST to create fancier reporting in certain cases
if desired.

Change-Id: I4ae98620b9b150fb5a389bd7f1e12670e3192c62
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6374
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index dc5d10c8e8..5dac971498 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -12,6 +12,7 @@ dirs = "4.0.0"
 path-clean = "0.1"
 tabwriter = { version = "1.2", optional = true }
 rowan = "*" # pinned by rnix
+codemap = "0.1.3"
 
 # rnix has not been released in a while (as of 2022-08-22), we will
 # use it from git.