about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-08T11·03+0200
committerclbot <clbot@tvl.fyi>2023-10-08T22·47+0000
commit269ab866f147c5eec4ab81e35ec0db11a2ea6ffb (patch)
tree7ea96ff1fa305f81184fc7cc16965b76f33bb62b /tvix/eval/Cargo.toml
parent4b27cdbc5727a4b196449d25f97f505cb517207e (diff)
refactor(tvix/eval/tests): migrate to tempfile r/6739
tempdir pulls in remove_dir_all 0.5.3 with
https://rustsec.org/advisories/RUSTSEC-2023-0018.html, and we use
tempfile everywhere else too, so let's just migrate to that.

Change-Id: I735ade7b65e12fc26e3d43ca95fcfa07fcc64642
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9565
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index cd5af7709c..2098d47061 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -35,7 +35,7 @@ xml-rs = "0.8.4"
 criterion = "0.4"
 pretty_assertions = "1.2.1"
 itertools = "0.10.3"
-tempdir = "0.3.7"
+tempfile = "3.3.0"
 
 [dev-dependencies.test-generator]
 # This fork of test-generator adds support for cargo workspaces, see