about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-16T12·33+0300
committertazjin <tazjin@tvl.su>2022-09-01T12·50+0000
commit16e9703f3810adc4f294fbc723c75f9107e89243 (patch)
treee97cd7d612f5de7dc1e125ae448366424b326581 /tvix/eval/Cargo.toml
parentf153a163a692215aa754218e18f6809f1ab0eb48 (diff)
refactor(tvix/eval): use pretty_assertions for tests r/4563
This makes for much more readable output especially when long strings
are involved.

Change-Id: I43dd73a0480535d7181a760788c42883a9b083f8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6229
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index b0ccabed2e..0416171c36 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -16,6 +16,7 @@ tabwriter = { version = "1.2", optional = true }
 [dev-dependencies]
 criterion = "0.3.6"
 test-generator = "0.3.0"
+pretty_assertions = "1.2.1"
 
 [features]
 # Enables running the Nix language test suite from the original C++