about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-08-25T15·04-0400
committergrfn <grfn@gws.fyi>2022-08-25T16·03+0000
commit0c4c307926232549f7cfca8f584fb66c31f60bf2 (patch)
tree8feba18ba43b8b6e017f0d7301452d6d2b896ccd /tvix/eval/Cargo.toml
parentf648cec78e9115527e4c135a9e3f7083abe9e5be (diff)
feat(tvix/eval): Add initial benchmarking infrastructure r/4489
Bootstrap some (initially very simple, mostly proof-of-concept)
benchmarking infrastructure using Criterion, using the newly-exposed lib
from tvix-eval.

Change-Id: I4bb93c142ba8d018d7e67e58ac8907a0429398a5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6156
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Autosubmit: grfn <grfn@gws.fyi>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 0a439a1897..4c1cf4f302 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -9,9 +9,14 @@ edition = "2021"
 rnix = "0.10.2"
 
 [dev-dependencies]
+criterion = "0.3.6"
 test-generator = "0.3.0"
 
 [features]
 # Enables running the Nix language test suite from the original C++
 # Nix implementation (at version 2.3) against Tvix.
 nix_tests = []
+
+[[bench]]
+name = "eval"
+harness = false