about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-21T19·32+0300
committerclbot <clbot@tvl.fyi>2023-09-22T12·51+0000
commit32f41458c0a0f62bf906021ef096c465ccc45581 (patch)
tree3aaab8c453871f39c46fb43f8278aa933b24519d /tvix/default.nix
parentd8ef0cfb4a859af7e33828b013356412d02532da (diff)
refactor(tvix): move castore into tvix-castore crate r/6629
This splits the pure content-addressed layers from tvix-store into a
`castore` crate, and only leaves PathInfo related things, as well as the
CLI entrypoint in the tvix-store crate.

Notable changes:
 - `fixtures` and `utils` had to be moved out of the `test` cfg, so they
   can be imported from tvix-store.
 - Some ad-hoc fixtures in the test were moved to proper fixtures in the
   same step.
 - The protos are now created by a (more static) recipe in the protos/
   directory.

The (now two) golang targets are commented out, as it's not possible to
update them properly in the same CL. This will be done by a followup CL
once this is merged (and whitby deployed)

Bug: https://b.tvl.fyi/issues/301

Change-Id: I8d675d4bf1fb697eb7d479747c1b1e3635718107
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9370
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix34
1 files changed, 25 insertions, 9 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 8082a13155..84d9730d19 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -36,8 +36,13 @@ let
         nativeBuildInputs = protobufDep prev;
       };
 
+      tvix-castore = prev: {
+        PROTO_ROOT = depot.tvix.proto;
+        nativeBuildInputs = protobufDep prev;
+      };
+
       tvix-store = prev: {
-        PROTO_ROOT = depot.tvix.store.protos;
+        PROTO_ROOT = depot.tvix.proto;
         nativeBuildInputs = protobufDep prev;
       };
     };
@@ -103,20 +108,26 @@ in
     ] ++ iconvDarwinDep;
   };
 
-  # Builds and tests the code in store/protos.
-  store-protos-go = pkgs.buildGoModule {
-    name = "store-golang";
-    src = depot.third_party.gitignoreSource ./store/protos;
+  # Builds and tests the code in castore/protos.
+  # castore-protos-go = pkgs.buildGoModule {
+  #   name = "castore-golang";
+  #   src = depot.third_party.gitignoreSource ./store/protos;
+  #   vendorHash = "sha256-00000000000000000000000000000000000000000000";
+  # };
 
-    vendorHash = "sha256-7xfXBBU3xJz7ifjk7Owm/byTfCQ8oaZtqXzBKhLqo00=";
-  };
+  # Builds and tests the code in store/protos.
+  # store-protos-go = pkgs.buildGoModule {
+  #   name = "store-golang";
+  #   src = depot.third_party.gitignoreSource ./store/protos;
+  #   vendorHash = "sha256-00000000000000000000000000000000000000000000";
+  # };
 
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
     inherit cargoDeps;
     name = "tvix-rust-docs";
     src = depot.third_party.gitignoreSource ./.;
-    PROTO_ROOT = depot.tvix.store.protos;
+    PROTO_ROOT = depot.tvix.proto;
 
     buildInputs = [
       pkgs.fuse
@@ -135,5 +146,10 @@ in
     '';
   };
 
-  meta.ci.targets = [ "store-protos-go" "shell" "rust-docs" ];
+  meta.ci.targets = [
+    # "castore-protos-go"
+    # "store-protos-go"
+    "shell"
+    "rust-docs"
+  ];
 }