about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-03-15T20·53+0200
committerclbot <clbot@tvl.fyi>2024-03-16T17·04+0000
commitdbf87f3057ea8468f7bedf8cc61203131fce1f9b (patch)
tree1529498cc55756918dad899ebe1a4307fc2ceaa4 /tvix/build/Cargo.toml
parent212f5afdcf28ce53006eebcc623a0256ff4aa33c (diff)
chore(tvix): bump tonic to 0.11.0 r/7705
This bumps tonic and surrounding crates to 0.11.x.

We added support for tonic 0.11.x into tokio-listener
(https://github.com/vi/tokio-listener/pull/4), so that's bumped as well.

Change-Id: Icfade5894403228299836fefb21b2f9ae59dbebb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11156
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 289dda4d8c..bda2d136c7 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -10,8 +10,8 @@ itertools = "0.12.0"
 prost = "0.12.1"
 thiserror = "1.0.56"
 tokio = { version = "1.32.0" }
-tokio-listener = { version = "0.2.2", features = [ "tonic010" ] }
-tonic = { version = "0.10.2", features = ["tls", "tls-roots"] }
+tokio-listener = { version = "0.3.2", features = [ "tonic011" ] }
+tonic = { version = "0.11.0", features = ["tls", "tls-roots"] }
 tvix-castore = { path = "../castore" }
 tracing = "0.1.37"
 tracing-subscriber = { version = "0.3.16", features = ["json"] }
@@ -19,11 +19,11 @@ url = "2.4.0"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.10.2"
+version = "0.11.0"
 
 [build-dependencies]
 prost-build = "0.12.1"
-tonic-build = "0.10.2"
+tonic-build = "0.11.0"
 
 [features]
 default = []