about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-07-20T18·15+0200
committerclbot <clbot@tvl.fyi>2024-07-21T11·01+0000
commitca8e2b9fbf4e58416655f237db02a331d0bc1f3d (patch)
tree0c14bd4a21e5367600cc9d0bcda563a33a879538 /tvix/build/Cargo.toml
parent1515a970bedbb6d7b5e8f966dddd0d8fff9bb03c (diff)
chore(tvix): upgrade to tonic 0.12 / hyper 1.0 r/8385
Change-Id: Idd8ce48869ddd869d51a10959b920f1290a8a9b3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11991
Autosubmit: yuka <yuka@yuka.dev>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 6faa3ad7abdb..c0cf86408087 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -7,11 +7,11 @@ edition = "2021"
 bytes = "1.4.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 itertools = "0.12.0"
-prost = "0.12.1"
+prost = "0.13.1"
 thiserror = "1.0.56"
 tokio = { version = "1.32.0" }
-tokio-listener = { version = "0.4.1", features = [ "tonic011" ] }
-tonic = { version = "0.11.0", features = ["tls", "tls-roots"] }
+tokio-listener = { version = "0.4.1", features = [ "tonic012" ] }
+tonic = { version = "0.12.0", features = ["tls", "tls-roots"] }
 tvix-castore = { path = "../castore" }
 tvix-tracing = { path = "../tracing" }
 tracing = "0.1.40"
@@ -19,11 +19,11 @@ url = "2.4.0"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.11.0"
+version = "0.12.0"
 
 [build-dependencies]
-prost-build = "0.12.1"
-tonic-build = "0.11.0"
+prost-build = "0.13.1"
+tonic-build = "0.12.0"
 
 [features]
 default = []