about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-08-27T10·02+0300
committerclbot <clbot@tvl.fyi>2024-08-27T10·34+0000
commit2fa5e71d5e768f45d743347187f70404b3771e79 (patch)
treee112f26c8ae4e98bde1b709636060d340826aa62 /tvix/build/Cargo.toml
parentd292203235ad69eea045febad7d59e2ac0e3a37d (diff)
fix(tvix/store): restore v1alpha reflection endpoint r/8593
tonic-reflection 0.12.x moved from the v1alpha to v1 of the reflection
protocol.

However, most clients, like Postman, Kreya and evans don't support that
one yet.

Bump tonic-reflection to 0.12.2, which re-introduces v1alpha support
alongside the v1 version of it, registering both services.

This fixes the example documented in tvix/store/README.md, it was
previously failing as evans couldn't find the v1alpha reflection
service.

See https://github.com/hyperium/tonic/pull/1888 for details.

Change-Id: I55438877317f82dc39face13afeb9594cda07a4e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12353
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: Ilan Joselevich <personal@ilanjoselevich.com>
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 8bb68783f0ea..6a10b41e2eaf 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -20,7 +20,7 @@ mimalloc = "0.1.43"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.12.0"
+version = "0.12.2"
 
 [build-dependencies]
 prost-build = "0.13.1"