about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-02-17T17·15+0100
committerflokli <flokli@flokli.de>2023-03-10T10·58+0000
commita40d2dcdcd453e44d53d44b4c1471f3b503c7cd6 (patch)
tree66d63a4ae80b107227deaef191ce148efd775109 /tvix/Cargo.nix
parentfbabcf0420bcc913971d529c11d58f6f888f1002 (diff)
feat(tvix/store): bump fastcdc, use v2020 version r/5925
This switches away from the less canonical "ronomon" version to the
implementation as described in the
[paper](https://ieeexplore.ieee.org/document/9055082) by Wen Xia, et
al., in 2020.

That version uses 64-bit hash values and tends to be faster than both
the ronomon and v2016 versions, and produces the same chunking as the
2016 version.

As per https://docs.rs/fastcdc/latest/fastcdc/#implementations-1, it's
the recommended choice.

The crate also gained support for streaming version of chunkers:
https://docs.rs/fastcdc/latest/fastcdc/#large-data, which might be
useful.

Change-Id: Ieabec3da54eb2b73c045cb54e51f7a216f63641e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8134
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 4e9e42e479..4d01c2f0de 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -1915,9 +1915,9 @@ rec {
       };
       "fastcdc" = rec {
         crateName = "fastcdc";
-        version = "2.0.0";
+        version = "3.0.0";
         edition = "2018";
-        sha256 = "1cbjm24yq0rpykb0lp4s5w4hvixj0k3m10w95sncd62h784ax4w0";
+        sha256 = "1qi398l32355b9kh0qr57rin86cv2z8kga25h1yis1wab9cjcxy4";
         authors = [
           "Nathan Fiedler <nathanfiedler@fastmail.fm>"
         ];