about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-11T19·25+0200
committerclbot <clbot@tvl.fyi>2023-12-11T22·46+0000
commit9748543f1c3edd88e8b05f6a772d6e9be18a7be9 (patch)
tree7c6a892c220e612b809bf703ab796a4bfa157bcb /tvix/Cargo.nix
parent6025be423a3dd97e29f536d39ca99528f58e5fb3 (diff)
chore(tvix): drop sled compression support r/7158
It's been a while since the last sled release, and that one binds to a
pretty old version of zstd, requiring workarounds like cl/10090.

Upstream sled main branch currently has zstd halfway patched out (it's
a no-op, but the feature flag and options are still there), and it's in
that state for a year.

Rather than maintaining our own fork of sled, let's just stop using the
compression feature in sled, dropping the version pin to zstd that way,
removing the need for cl/10090.

This doesn't mean we won't reintroduce per-blob compression - but we
probably just won't let sled take care of the compression, but do it
ourselves - which is necessary for more chunked blob storage anyways.

Even though we do drop the feature flag, we still need to explicitly use
use_compression(false).

Change-Id: I0e4892d29e41c76653272dc1a3625180da6fee12
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10257
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 826ebf3208..5e4b54d9d1 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -7426,11 +7426,6 @@ rec {
             name = "parking_lot";
             packageId = "parking_lot 0.11.2";
           }
-          {
-            name = "zstd";
-            packageId = "zstd";
-            optional = true;
-          }
         ];
         devDependencies = [
           {
@@ -7450,7 +7445,7 @@ rec {
           "testing" = [ "event_log" "lock_free_delays" "compression" "failpoints" "backtrace" ];
           "zstd" = [ "dep:zstd" ];
         };
-        resolvedDefaultFeatures = [ "compression" "default" "no_metrics" "zstd" ];
+        resolvedDefaultFeatures = [ "default" "no_metrics" ];
       };
       "smallvec" = rec {
         crateName = "smallvec";
@@ -9457,7 +9452,6 @@ rec {
           {
             name = "sled";
             packageId = "sled";
-            features = [ "compression" ];
           }
           {
             name = "thiserror";
@@ -9980,7 +9974,6 @@ rec {
           {
             name = "sled";
             packageId = "sled";
-            features = [ "compression" ];
           }
           {
             name = "thiserror";