about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-09T10·53+0200
committerclbot <clbot@tvl.fyi>2023-12-11T22·35+0000
commit8486f87e3c180732d04e58154762c016c054d776 (patch)
treed555a1cd622bb4e9836314dd2bcb777f9b20ef82 /tvix/Cargo.nix
parent92bd69aef23126412a15649e441339c96e001212 (diff)
feat(tvix/build): add derivation_to_build_request r/7154
This function converts from a nix_compat::derivation::Derivation to
a BuildRequest.

In addition to the Derivation itself, it needs two lookup functions to
map input paths to their castore nodes.

Change-Id: I0332982f0bc7933a5fda137fe39d5a850639d929
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10236
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 6151fd76d3..826ebf3208 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -9370,6 +9370,10 @@ rec {
           else ./build;
         dependencies = [
           {
+            name = "bytes";
+            packageId = "bytes";
+          }
+          {
             name = "prost";
             packageId = "prost";
           }
@@ -9819,6 +9823,11 @@ rec {
             packageId = "tracing";
           }
           {
+            name = "tvix-build";
+            packageId = "tvix-build";
+            usesDefaultFeatures = false;
+          }
+          {
             name = "tvix-castore";
             packageId = "tvix-castore";
           }
@@ -9838,6 +9847,10 @@ rec {
         ];
         devDependencies = [
           {
+            name = "lazy_static";
+            packageId = "lazy_static";
+          }
+          {
             name = "test-case";
             packageId = "test-case";
           }