about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorPicnoir <picnoir@alternativebit.fr>2024-03-21T08·52+0100
committerpicnoir picnoir <picnoir@alternativebit.fr>2024-03-27T12·05+0000
commit21481b02b872900b881c2c489e085e44f1b90b0f (patch)
tree7eeb75aa809f73d1bd04f090a6521165333b2ce5 /tvix/Cargo.nix
parent508d67ad49917c293c34f3c9ca59adcea02ea3ef (diff)
feat(tvix/nix-compat): worker protocol operation parser r/7784
Change-Id: I7776635b17c44534223603d28cf59c7eebd976e0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11229
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix38
1 files changed, 36 insertions, 2 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 0f0268bfe7..001b63d526 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -2692,6 +2692,32 @@ rec {
         ];
 
       };
+      "enum-primitive-derive" = rec {
+        crateName = "enum-primitive-derive";
+        version = "0.3.0";
+        edition = "2018";
+        sha256 = "0k6wcf58h5kh64yq5nfq71va53kaya0kzxwsjwbgwm2n2zd9axxs";
+        procMacro = true;
+        authors = [
+          "Doug Goldstein <cardoe@cardoe.com>"
+        ];
+        dependencies = [
+          {
+            name = "num-traits";
+            packageId = "num-traits";
+            usesDefaultFeatures = false;
+          }
+          {
+            name = "quote";
+            packageId = "quote 1.0.35";
+          }
+          {
+            name = "syn";
+            packageId = "syn 2.0.48";
+          }
+        ];
+
+      };
       "equivalent" = rec {
         crateName = "equivalent";
         version = "1.0.1";
@@ -5722,6 +5748,10 @@ rec {
             packageId = "ed25519-dalek";
           }
           {
+            name = "enum-primitive-derive";
+            packageId = "enum-primitive-derive";
+          }
+          {
             name = "futures-util";
             packageId = "futures-util";
             optional = true;
@@ -5736,6 +5766,10 @@ rec {
             packageId = "nom";
           }
           {
+            name = "num-traits";
+            packageId = "num-traits";
+          }
+          {
             name = "serde";
             packageId = "serde";
             features = [ "derive" ];
@@ -5886,9 +5920,9 @@ rec {
       };
       "num-traits" = rec {
         crateName = "num-traits";
-        version = "0.2.17";
+        version = "0.2.18";
         edition = "2018";
-        sha256 = "0z16bi5zwgfysz6765v3rd6whfbjpihx3mhsn4dg8dzj2c221qrr";
+        sha256 = "0yjib8p2p9kzmaz48xwhs69w5dh1wipph9jgnillzd2x33jz03fs";
         authors = [
           "The Rust Project Developers"
         ];