about summary refs log tree commit diff
path: root/tools/nixery/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-12T16·53+0100
committerVincent Ambo <github@tazj.in>2019-08-13T23·02+0100
commitf60f702274191f87b23dab5393420b27a50952fc (patch)
treed038149a640d582ad47605111a9deec3b011cb7a /tools/nixery/shell.nix
parent6035bf36eb93bc30db6ac40739913358e71d1121 (diff)
feat: Add shell.nix for running a local Nixery
Diffstat (limited to 'tools/nixery/shell.nix')
-rw-r--r--tools/nixery/shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/nixery/shell.nix b/tools/nixery/shell.nix
new file mode 100644
index 0000000000..49d0e55819
--- /dev/null
+++ b/tools/nixery/shell.nix
@@ -0,0 +1,27 @@
+# Copyright 2019 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Configures a shell environment that builds required local packages to
+# run Nixery.
+{pkgs ? import <nixpkgs> {} }:
+
+let nixery = import ./default.nix { inherit pkgs; };
+in pkgs.stdenv.mkDerivation {
+  name = "nixery-dev-shell";
+
+  buildInputs = with pkgs;[
+    jq
+    nixery.nixery-build-image
+  ];
+}