about summary refs log tree commit diff
path: root/tools/nixery/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-11T21·07+0000
committerVincent Ambo <github@tazj.in>2019-11-27T14·12+0000
commit2b82f1b71a50b8b1473421cce0eec1a0d7ddc360 (patch)
treed42dcfd823f63ac77d3517b3c3154619f87f2cd2 /tools/nixery/shell.nix
parentdf88da126a5c0dc97aa0fadaf1baf069b80ce251 (diff)
refactor: Reshuffle file structure for better code layout
This gets rid of the package called "server" and instead moves
everything into the project root, such that Go actually builds us a
binary called `nixery`.

This is the first step towards factoring out CLI-based functionality
for Nixery.
Diffstat (limited to 'tools/nixery/shell.nix')
-rw-r--r--tools/nixery/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/nixery/shell.nix b/tools/nixery/shell.nix
index 93cd1f4cec..b37caa83ad 100644
--- a/tools/nixery/shell.nix
+++ b/tools/nixery/shell.nix
@@ -20,5 +20,5 @@ let nixery = import ./default.nix { inherit pkgs; };
 in pkgs.stdenv.mkDerivation {
   name = "nixery-dev-shell";
 
-  buildInputs = with pkgs; [ jq nixery.nixery-build-image ];
+  buildInputs = with pkgs; [ jq nixery.nixery-prepare-image ];
 }