about summary refs log tree commit diff
path: root/tools/nixery/prepare-image/load-pkgs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-04-20T14·41+0200
committerclbot <clbot@tvl.fyi>2022-04-20T15·31+0000
commit6716bf018c465f4b943eef0e6716caa7a54940da (patch)
tree8e609da0ed0052f4088250ecc1033c28d35f5d6c /tools/nixery/prepare-image/load-pkgs.nix
parent535ad8732a688bf6ff4c48283d89dae00262a719 (diff)
chore(nixery): Housekeeping for depot compatibility r/3982
Cleans up a whole bunch of things I wanted to get out of the door
right away:

* depot internal references to //third_party/nixery have been replaced
  with //tools/nixery
* cleaned up files from Github
* fixed SPDX & Copyright headers
* code formatting and inclusion in //tools/depotfmt checks

Change-Id: Iea79f0fdf3aa04f71741d4f4032f88605ae415bb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5486
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tools/nixery/prepare-image/load-pkgs.nix')
-rw-r--r--tools/nixery/prepare-image/load-pkgs.nix21
1 files changed, 6 insertions, 15 deletions
diff --git a/tools/nixery/prepare-image/load-pkgs.nix b/tools/nixery/prepare-image/load-pkgs.nix
index 4a89dcde3a..7f8ab5479d 100644
--- a/tools/nixery/prepare-image/load-pkgs.nix
+++ b/tools/nixery/prepare-image/load-pkgs.nix
@@ -1,16 +1,5 @@
-# Copyright 2019 Google LLC
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-#     https://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
+# Copyright 2022 The TVL Contributors
+# SPDX-License-Identifier: Apache-2.0
 
 # Load a Nix package set from one of the supported source types
 # (nixpkgs, git, path).
@@ -24,7 +13,8 @@ let
     let
       url =
         "https://github.com/NixOS/nixpkgs/archive/${channel}.tar.gz";
-    in import (fetchTarball url) importArgs;
+    in
+    import (fetchTarball url) importArgs;
 
   # If a git repository is requested, it is retrieved via
   # builtins.fetchGit which defaults to the git configuration of the
@@ -35,7 +25,8 @@ let
   # No special handling is used for paths, so users are expected to pass one
   # that will work natively with Nix.
   importPath = path: import (toPath path) importArgs;
-in if srcType == "nixpkgs" then
+in
+if srcType == "nixpkgs" then
   fetchImportChannel srcArgs
 else if srcType == "git" then
   fetchImportGit (fromJSON srcArgs)