about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-10-27T14·33+0100
committerVincent Ambo <github@tazj.in>2019-10-28T21·31+0100
commitffe58d6cb510d0274ea1afed3e0e2b44c69e32c2 (patch)
tree691d96e81ba0ab4715bf22932f50431e8b5f3d2f /tools/nixery/default.nix
parent7b7d21205fb5288f1772d6ea4baff080565ebd9e (diff)
refactor(build): Do not expose nixery-server attribute
In most cases this is not useful for users without the wrapper script,
so users should always build nixery-bin anyways.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 422148d626..3541037965 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -18,7 +18,7 @@
 
 with pkgs;
 
-rec {
+let
   # Hash of all Nixery sources - this is used as the Nixery version in
   # builds to distinguish errors between deployed versions, see
   # server/logs.go for details.
@@ -29,13 +29,11 @@ rec {
   # Go implementation of the Nixery server which implements the
   # container registry interface.
   #
-  # Users will usually not want to use this directly, instead see the
-  # 'nixery' derivation below, which automatically includes runtime
-  # data dependencies.
+  # Users should use the nixery-bin derivation below instead.
   nixery-server = callPackage ./server {
     srcHash = nixery-src-hash;
   };
-
+in rec {
   # Implementation of the Nix image building logic
   nixery-build-image = import ./build-image { inherit pkgs; };