about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-22T16·51+0100
committerVincent Ambo <github@tazj.in>2019-09-22T17·04+0100
commitad9b3eb2629b0716d93ce07411831d859237edff (patch)
tree34b20b895a9a55776b13463b3aef581e6ea4d7a7 /tools/nixery/default.nix
parent7b987530d1e1d25c74b6f8a85a9a25ef61a32c15 (diff)
refactor(build): Add group-layers to top-level Nix derivations
This makes CI build the group-layers tool (and cache it to Cachix!)
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 66155eefa0..95540e11da 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -17,7 +17,11 @@
 
 with pkgs;
 
-rec {
+let buildImage = import ./build-image {
+  srcType = "path";
+  srcArgs = <nixpkgs>;
+};
+in rec {
   # Go implementation of the Nixery server which implements the
   # container registry interface.
   #
@@ -27,10 +31,8 @@ rec {
   nixery-server = callPackage ./server { };
 
   # Implementation of the image building & layering logic
-  nixery-build-image = (import ./build-image {
-    srcType = "path";
-    srcArgs = <nixpkgs>;
-  }).wrapper;
+  nixery-build-image = buildImage.wrapper;
+  nixery-group-layers = buildImage.groupLayers;
 
   # Use mdBook to build a static asset page which Nixery can then
   # serve. This is primarily used for the public instance at