about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorJérôme Petazzoni <jerome.petazzoni@gmail.com>2021-04-22T14·52+0200
committerVincent Ambo <mail@tazj.in>2021-06-25T23·27+0200
commit94e04a76b6d2baf0cc5060c3168a428fae6c28ab (patch)
tree04a5038cb960b7f49aa7a18baf4f094423ce057c /tools/nixery/default.nix
parent3efbbfcd4e22811dd549c6ed46374736308b0b82 (diff)
feat(storage): Store blob content-type in extended attributes
After the discussion in #116, this stores the blob content types
in extended attributes when using the filesystem backend.

If the underlying filesystem doesn't support extended attributes,
storing blobs won't work; also, if extended attributes get removed,
blobs won't be served anymore. We can relax this behavior if
needed (i.e. log errors but still accept to store or serve blobs).
However, since the Docker Engine (and possibly other container
engines) won't accept to pull images from a registry that doesn't
use correct content types for manifest files, it could be argued
that it's better to give a hard fail. (Otherwise, the container
engine gives cryptic error messages like "missing signature key".)

I can change that behavior (and log errors but still store/serve
blobs to the filesystem) if you think it's better.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index a5cc61e7e2..3900353751 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -38,7 +38,7 @@ let
     doCheck = true;
 
     # Needs to be updated after every modification of go.mod/go.sum
-    vendorSha256 = "1ff0kfww6fy6pnvyva7x8cc6l1d12aafps48wrkwawk2qjy9a8b9";
+    vendorSha256 = "1adjav0dxb97ws0w2k50rhk6r46wvfry6aj4sik3ninl525kd15s";
 
     buildFlagsArray = [
       "-ldflags=-s -w -X main.version=${nixery-commit-hash}"