about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-04T21·43+0100
committerVincent Ambo <github@tazj.in>2019-08-04T23·32+0100
commit85e8d760fcf16e50ba8e055561ac418f4f5bce58 (patch)
tree6157585e51bc66348e2ae58272cc5b9da33c7732 /tools/nixery/default.nix
parent7c41a7a8723c8bd6606c0c2f3fed3a546f1efb24 (diff)
feat(build): Add mdBook 0.3.1 to build environment
Upstream nixpkgs currently only has an older versin of mdBook. Until
that changes, we keep a different version in here.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 7c7ad0b6c0..28b94af5bd 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -55,6 +55,24 @@ rec {
     mkdir $out
     cp ${./static}/* $out
   '';
+  # nixpkgs currently has an old version of mdBook. A new version is
+  # built here, but eventually the update will be upstreamed
+  # (nixpkgs#65890)
+  mdbook = rustPlatform.buildRustPackage rec {
+    name = "mdbook-${version}";
+    version = "0.3.1";
+    doCheck = false;
+
+    src = fetchFromGitHub {
+      owner = "rust-lang-nursery";
+      repo = "mdBook";
+      rev = "v${version}";
+      sha256 = "0py69267jbs6b7zw191hcs011cm1v58jz8mglqx3ajkffdfl3ghw";
+    };
+
+    cargoSha256 = "0qwhc42a86jpvjcaysmfcw8kmwa150lmz01flmlg74g6qnimff5m";
+  };
+
 
   # Wrapper script running the Nixery server with the above two data
   # dependencies configured.