about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-17T09·29+0000
committerVincent Ambo <github@tazj.in>2019-08-17T09·42+0100
commit745b7ce0b821b1d46b7259c8ba704bf767ad31d6 (patch)
tree4a3f06759a454961021637514a1d2d4b04b7735b /tools/nixery/default.nix
parent9a95c4124f911dbc07d4eabc0c4b8fc2d44c74d6 (diff)
fix(build): Ensure root user is known inside of container
This is required by git in cases where Nixery is configured with a
custom git repository.

I've also added a shell back into the image to make debugging a
running Nixery easier. It turns out some of the dependencies already
pull in bash anyways, so this is just surfacing it to $PATH.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 734a72d57e..194cf54608 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -61,6 +61,8 @@ rec {
       # Create the build user/group required by Nix
       echo 'nixbld:x:30000:nixbld' >> /etc/group
       echo 'nixbld:x:30000:30000:nixbld:/tmp:/bin/bash' >> /etc/passwd
+      echo 'root:x:0:0:root:/root:/bin/bash' >> /etc/passwd
+      echo 'root:x:0:' >> /etc/group
 
       # Disable sandboxing to avoid running into privilege issues
       mkdir -p /etc/nix
@@ -80,6 +82,7 @@ rec {
     config.Cmd = [ "${nixery-launch-script}/bin/nixery" ];
     maxLayers = 96;
     contents = [
+      bashInteractive
       cacert
       coreutils
       git
@@ -89,6 +92,7 @@ rec {
       nixery-build-image
       nixery-launch-script
       openssh
+      zlib
     ];
   };
 }