about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-12T14·14+0100
committerVincent Ambo <github@tazj.in>2019-08-13T23·02+0100
commit1fa93fe6f640bfdbb5e9ecedb2dbf2cacc5e8945 (patch)
tree636e454066d324758c9acdc10ad72607f4d35b99 /tools/nixery/default.nix
parentd699f7f91cb0b90f15199f6d6884442594cb6c56 (diff)
refactor: Move registry server to a subfolder
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix22
1 files changed, 2 insertions, 20 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 092c76e9c5..dee5713c64 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -23,29 +23,11 @@ rec {
   # Users will usually not want to use this directly, instead see the
   # 'nixery' derivation below, which automatically includes runtime
   # data dependencies.
-  nixery-server = buildGoPackage {
-    name = "nixery-server";
-
-    # Technically people should not be building Nixery through 'go get'
-    # or similar (as other required files will not be included), but
-    # buildGoPackage requires a package path.
-    goPackagePath = "github.com/google/nixery";
-    goDeps = ./go-deps.nix;
-    src    = ./.;
-
-    meta = {
-      description = "Container image build serving Nix-backed images";
-      homepage    = "https://github.com/google/nixery";
-      license     = lib.licenses.asl20;
-      maintainers = [ lib.maintainers.tazjin ];
-    };
-  };
+  nixery-server = callPackage ./server {};
 
   # Nix expression (unimported!) which is used by Nixery to build
   # container images.
-  nixery-builder = runCommand "build-registry-image.nix" {} ''
-    cat ${./build-registry-image.nix} > $out
-  '';
+  nixery-builder = ./build-registry-image.nix;
 
   # nixpkgs currently has an old version of mdBook. A new version is
   # built here, but eventually the update will be upstreamed