about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-10-03T21·16+0100
committerVincent Ambo <github@tazj.in>2019-10-03T21·29+0100
commit0d820423e973727ddfc4b461a1063f719873743c (patch)
tree94edf81162325e5039e06eff0c84ccce3dcc0988 /tools/nixery/default.nix
parent6b06fe27be2dcf0741ff7981838fbb3a022181b7 (diff)
chore(build-image): Remove nixery-build-layers
This functionality has been rolled into the server component and is no
longer required.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index af506eea32..b194079b9a 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -18,8 +18,7 @@
 
 with pkgs;
 
-let builders = import ./build-image { inherit pkgs; };
-in rec {
+rec {
   # Go implementation of the Nixery server which implements the
   # container registry interface.
   #
@@ -29,8 +28,7 @@ in rec {
   nixery-server = callPackage ./server { };
 
   # Implementation of the Nix image building logic
-  nixery-build-image = builders.build-image;
-  nixery-build-layers = builders.build-layers;
+  nixery-build-image = import ./build-image { inherit pkgs; };
 
   # Use mdBook to build a static asset page which Nixery can then
   # serve. This is primarily used for the public instance at
@@ -44,7 +42,7 @@ in rec {
   # are installing Nixery directly.
   nixery-bin = writeShellScriptBin "nixery" ''
     export WEB_DIR="${nixery-book}"
-    export PATH="${nixery-build-layers}/bin:${nixery-build-image}/bin:$PATH"
+    export PATH="${nixery-build-image}/bin:$PATH"
     exec ${nixery-server}/bin/nixery
   '';
 
@@ -96,7 +94,6 @@ in rec {
       iana-etc
       nix
       nixery-build-image
-      nixery-build-layers
       nixery-launch-script
       openssh
       zlib