about summary refs log tree commit diff
path: root/tools/eaglemode/plugins/avif/default.nix
diff options
context:
space:
mode:
authorEmery Hemingway <emery@dmz.rs>2024-09-03T10·54+0300
committeremery <emery@dmz.rs>2024-09-03T19·44+0000
commit1c898f7ddc5b3ad223d73972465c9fee206c9815 (patch)
treeefb35c2af80c74073cf2d956bf4ed91c24a848f7 /tools/eaglemode/plugins/avif/default.nix
parente4714db2d5f2b38b60f1ec8a200d0eb3bea0d79f (diff)
feat(tools/eaglemode/plugins/avif): AVIF image plugin r/8647
Animation not implemented.
https: //en.wikipedia.org/wiki/AVIF

Change-Id: I80f8c4132c4335b2e60ce7b70eb424457e50c73f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12428
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tools/eaglemode/plugins/avif/default.nix')
-rw-r--r--tools/eaglemode/plugins/avif/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/eaglemode/plugins/avif/default.nix b/tools/eaglemode/plugins/avif/default.nix
new file mode 100644
index 000000000000..5def86a6ed82
--- /dev/null
+++ b/tools/eaglemode/plugins/avif/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+let
+  em = depot.tools.eaglemode;
+  emSrc = pkgs.srcOnly pkgs.em;
+in
+(em.buildPlugin {
+  name = "avif";
+  version = "canon";
+  src = ./.;
+  target = "PlAvif";
+}).overrideAttrs
+  ({ buildInputs ? [ ], nativeBuildInputs ? [ ], ... }: {
+    buildInputs = buildInputs ++ [ pkgs.libavif ];
+    nativeBuildInputs = nativeBuildInputs ++ [ pkgs.pkg-config ];
+  })