about summary refs log tree commit diff
path: root/third_party/python/broadlink/setup.py
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-04-25T17·22+0100
committerVincent Ambo <tazjin@google.com>2020-04-25T17·22+0100
commit9d94a727b27016e21fe904a555a3742d3c5b1eb9 (patch)
treed8296ca4ac06e089751dc3ca9fff08f8c6d7912a /third_party/python/broadlink/setup.py
parent0f530601596c17ac090f00b7fc99fe4033d6a2e4 (diff)
parent17968ef4d40e7cb484909b3ddad33d7795b80091 (diff)
Add 'third_party/python/broadlink/' from commit '17968ef4d40e7cb484909b3ddad33d7795b80091' r/680
git-subtree-dir: third_party/python/broadlink
git-subtree-mainline: 0f530601596c17ac090f00b7fc99fe4033d6a2e4
git-subtree-split: 17968ef4d40e7cb484909b3ddad33d7795b80091
Diffstat (limited to 'third_party/python/broadlink/setup.py')
-rw-r--r--third_party/python/broadlink/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/python/broadlink/setup.py b/third_party/python/broadlink/setup.py
new file mode 100644
index 0000000000..778f495fb5
--- /dev/null
+++ b/third_party/python/broadlink/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+
+from setuptools import setup, find_packages
+
+
+version = '0.13.2'
+
+setup(
+    name='broadlink',
+    version=version,
+    author='Matthew Garrett',
+    author_email='mjg59@srcf.ucam.org',
+    url='http://github.com/mjg59/python-broadlink',
+    packages=find_packages(),
+    scripts=[],
+    install_requires=['cryptography>=2.1.1'],
+    description='Python API for controlling Broadlink IR controllers',
+    classifiers=[
+        'Development Status :: 4 - Beta',
+        'Intended Audience :: Developers',
+        'License :: OSI Approved :: MIT License',
+        'Operating System :: OS Independent',
+        'Programming Language :: Python',
+    ],
+    include_package_data=True,
+    zip_safe=False,
+)