about summary refs log tree commit diff
path: root/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-06-19T13·56+0200
committerProfpatsch <mail@profpatsch.de>2023-07-14T08·03+0000
commit07b976ccd89cc8a4b5d0624ee2223d64add4615d (patch)
tree559db5d16d23cbb7f576448fccccb9a5f84e85e7 /third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
parent5daa31db3ba0a7dbe2a5f8ef01b024deb61fcc3e (diff)
feat(users/Profpatsch): init whatcd-resolver r/6413
Change-Id: Ieb377fb8caa60e716703153dfeca5173f9a6779d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8830
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix')
-rw-r--r--third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix b/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
new file mode 100644
index 0000000000..56ee6eb2d1
--- /dev/null
+++ b/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
@@ -0,0 +1,43 @@
+{ mkDerivation
+, aeson
+, aeson-better-errors
+, aeson-pretty
+, base
+, bytestring
+, containers
+, hspec-core
+, hspec-expectations
+, lib
+, pa-error-tree
+, pa-label
+, pa-prelude
+, scientific
+, text
+, time
+, vector
+}:
+mkDerivation {
+  pname = "pa-json";
+  version = "0.2.0.0";
+  sha256 = "b57ef3888b8ea3230925675eccd6affbc3d296fc8762f5937435af4bdbd276e4";
+  libraryHaskellDepends = [
+    aeson
+    aeson-better-errors
+    aeson-pretty
+    base
+    bytestring
+    containers
+    hspec-core
+    hspec-expectations
+    pa-error-tree
+    pa-label
+    pa-prelude
+    scientific
+    text
+    time
+    vector
+  ];
+  homepage = "https://github.com/possehl-analytics/pa-hackage";
+  description = "Our JSON parsers/encoders";
+  license = lib.licenses.bsd3;
+}