about summary refs log tree commit diff
path: root/third_party/overlays/dhall/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-09-25T13·34+0200
committerclbot <clbot@tvl.fyi>2022-09-25T14·17+0000
commitd44203d04669ff29b3047154a1f2707f4fe42c34 (patch)
treeb12dfeb6afa4d0be2551e986519d0415915f30a0 /third_party/overlays/dhall/default.nix
parente7d24fd2b8baea2c229a324ceae7259793b0e5e0 (diff)
fix(third_party/overlays/dhall): move haskellPackages overlay r/4965
It was overriding the overrides in haskellPackages, which we didn’t
notice because there is no overrides in the hasell overlay atm.

I also removed the `with` blocks and inlined `overrides`.

Change-Id: Ide72109dbd2568b6cb2435b15024cf1523bec1fe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6785
Autosubmit: Profpatsch <mail@profpatsch.de>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/overlays/dhall/default.nix')
-rw-r--r--third_party/overlays/dhall/default.nix18
1 files changed, 2 insertions, 16 deletions
diff --git a/third_party/overlays/dhall/default.nix b/third_party/overlays/dhall/default.nix
index d944905e8d..4625035999 100644
--- a/third_party/overlays/dhall/default.nix
+++ b/third_party/overlays/dhall/default.nix
@@ -3,15 +3,6 @@
 self: super:
 
 let
-  dhall-source = subdir: pkg: super.haskell.lib.overrideSrc pkg {
-    src = "${super.fetchFromGitHub {
-      owner = "Profpatsch";
-      repo = "dhall-haskell";
-      # https://github.com/dhall-lang/dhall-haskell/pull/2426
-      rev = "82123817316192d39f9a3e68b8ce9c9cff0a48ed";
-      sha256 = "sha256-gbHoUKIdLPIttqeV471jsT8OJz6uiI6LpHOwtLbBGHY=";
-    }}/${subdir}";
-  };
 
   # binary releases of dhall tools, since the build in nixpkgs is
   # broken most of the time. The binaries are also fully static
@@ -25,13 +16,8 @@ let
       { pkgs = self; };
 in
 {
-  # TODO: this is to fix a bug in dhall-nix
-  haskellPackages = super.haskellPackages.override {
-    overrides = hsSelf: hsSuper: {
-      dhall = dhall-source "dhall" hsSuper.dhall;
-      dhall-nix = dhall-source "dhall-nix" hsSuper.dhall-nix;
-    };
-  };
+  # ATTN: see the haskell overlay for some overrides we need.
+
   # dhall = easy-dhall-nix.dhall-simple;
   # dhall-nix = easy-dhall-nix.dhall-nix-simple;
   dhall-bash = easy-dhall-nix.dhall-bash-simple;