about summary refs log tree commit diff
path: root/third_party/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-09T03·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-09T03·18+0000
commit97be9c1411aca437daa9eb95474ee134e727a3d9 (patch)
treecbb41d206da53d107e4e398d5713b9f2827332ad /third_party/nixery/default.nix
parentff38ae6c5f64ceadb307eac95bbe63e7a55f80c6 (diff)
fix(third_party): Shuffle code around to be compatible with readTree r/106
As per the previous commit these files were no longer being imported,
which is now fixed by moving them into separate subfolders.
Diffstat (limited to 'third_party/nixery/default.nix')
-rw-r--r--third_party/nixery/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/nixery/default.nix b/third_party/nixery/default.nix
new file mode 100644
index 0000000000..b4c0837651
--- /dev/null
+++ b/third_party/nixery/default.nix
@@ -0,0 +1,18 @@
+# Technically I suppose Nixery is not a third-party program, but it's
+# outside of this repository ...
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "google";
+  repo = "nixery";
+  rev = "4f6ce83f9296545d6c74321b37d18545764c8827";
+  sha256 = "19aiak1pss6vwm0fwn02827l5ir78fkqglfbdl2gchsyv3gps8bg";
+};
+in import src {
+  pkgs = pkgs.third_party;
+  preLaunch = ''
+    export USER=root
+    cachix use tazjin
+  '';
+  extraPackages = [ pkgs.third_party.cachix ];
+}