about summary refs log tree commit diff
path: root/third_party/nix/test-vm.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-12T20·26+0200
committertazjin <mail@tazj.in>2021-04-12T21·55+0000
commitf520bd40cab9bae4f8fa26fe36365a7bf9bccd5a (patch)
tree5f116d10e44b7f3616fb63c28e7de03d81869071 /third_party/nix/test-vm.nix
parenta5591359702b62e4edd7fdbbd135475037aa6727 (diff)
refactor: Replace 'depotPath' with 'depot.path' r/2497
Instead of having two ways of accessing the path to the depot (one of
which was stuttering, depot.depotPath) we settle on only one:
depot.path.

This was mostly used for NixOS module imports.

Co-Authored-By: Florian Klink <flokli@flokli.de>
Change-Id: I2c0db23383fc34f6ca76baaad4cc4af2d9dfae15
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2962
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/nix/test-vm.nix')
-rw-r--r--third_party/nix/test-vm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/nix/test-vm.nix b/third_party/nix/test-vm.nix
index 550537679c..e5f8690fcb 100644
--- a/third_party/nix/test-vm.nix
+++ b/third_party/nix/test-vm.nix
@@ -11,7 +11,7 @@ let
     virtualisation.qemu.options = [ "-nographic" "-curses" ];
 
     nix.nixPath = [
-      "depot=${depot.depotPath}"
+      "depot=${depot.path}"
     ];
   };