about summary refs log tree commit diff
path: root/third_party/nix/test-vm.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-09-01T00·58-0400
committerglittershark <grfn@gws.fyi>2020-09-01T01·07+0000
commite472aa016e4d8bef79930d750c65e40ce21dba3a (patch)
treef07bc531d471ba312d52ad72de466b3682aec88d /third_party/nix/test-vm.nix
parent912268ed5e009c08ad5309673d3c5c5633453a0a (diff)
feat(tvix): Expose depot in the test vm r/1754
Expose depot to the test vm via NIX_PATH, so we can test the build of
depot packages from inside the test vm.

Change-Id: I26314634895ab1339f5715c0b0b261028eefdaa3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1923
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/test-vm.nix')
-rw-r--r--third_party/nix/test-vm.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/third_party/nix/test-vm.nix b/third_party/nix/test-vm.nix
index 534a3fc930..2a10568268 100644
--- a/third_party/nix/test-vm.nix
+++ b/third_party/nix/test-vm.nix
@@ -10,6 +10,10 @@ let
     nix.package = depot.third_party.nix;
 
     virtualisation.qemu.options = [ "-nographic" ];
+
+    nix.nixPath = [
+      "depot=${depot.depotPath}"
+    ];
   };
 
   system = pkgs.nixos { inherit configuration; };