about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-attrs3.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/tests/lang/eval-okay-attrs3.nix
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-attrs3.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-attrs3.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-attrs3.nix b/third_party/nix/src/tests/lang/eval-okay-attrs3.nix
deleted file mode 100644
index f29de11fe6..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-attrs3.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-let
-
-  config = 
-    {
-      services.sshd.enable = true;
-      services.sshd.port = 22;
-      services.httpd.port = 80;
-      hostName = "itchy";
-      a.b.c.d.e.f.g.h.i.j.k.l.m.n.o.p.q.r.s.t.u.v.w.x.y.z = "x";
-      foo = {
-        a = "a";
-        b.c = "c";
-      };
-    };
-
-in
-  if config.services.sshd.enable
-  then "foo ${toString config.services.sshd.port} ${toString config.services.httpd.port} ${config.hostName}"
-       + "${config.a.b.c.d.e.f.g.h.i.j.k.l.m.n.o.p.q.r.s.t.u.v.w.x.y.z}"
-       + "${config.foo.a}"
-       + "${config.foo.b.c}"
-  else "bar"