about summary refs log tree commit diff
path: root/third_party/nix/src/libstore/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T16·23+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T20·42+0000
commit8b83e0f31b7d4b56718a634ebdbc22b18728d384 (patch)
treec89e89c939c4a21141f4b8460e2f87c3fcb350db /third_party/nix/src/libstore/CMakeLists.txt
parent739a45f9e47f35680117af61dc1a3aa2f5615636 (diff)
feat(3p/nix): install pkgconfig files for libexpr, libmain and libstore r/1052
Also fixes the pkgconfig files to use the corresponding CMake variables.

Change-Id: I8095b8aff39ad91e592f3edc95555c9f1f1f153d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/545
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/src/libstore/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libstore/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/third_party/nix/src/libstore/CMakeLists.txt b/third_party/nix/src/libstore/CMakeLists.txt
index 7661e44e07..4bc7b8fd5d 100644
--- a/third_party/nix/src/libstore/CMakeLists.txt
+++ b/third_party/nix/src/libstore/CMakeLists.txt
@@ -103,5 +103,8 @@ target_link_libraries(nixstore
   sodium
 )
 
+configure_file("nix-store.pc.in" "${PROJECT_BINARY_DIR}/nix-store.pc" @ONLY)
+INSTALL(FILES "${PROJECT_BINARY_DIR}/nix-store.pc" DESTINATION "${PKGCONFIG_INSTALL_DIR}")
+
 INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libstore)
 INSTALL(TARGETS nixstore DESTINATION ${CMAKE_INSTALL_LIBDIR})