about summary refs log tree commit diff
path: root/third_party/nix/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-05-18T15·39+0200
committerclbot <clbot@tvl.fyi>2022-05-19T14·08+0000
commitd127f9bd0e7b9b2e0df2de8a2227f77c0907468d (patch)
tree68455040d88b8e0c2817601db88ede450873ff8e /third_party/nix/src/CMakeLists.txt
parentc85291c602ac666421627d6934ebc6d5be1b93e1 (diff)
chore(3p/nix): unvendor tvix 0.1 r/4098
Nothing is using this now, and we'll likely never pick this up again,
but we learned a lot in the process.

Every now and then this breaks in some bizarre way on channel bumps
and it's just a waste of time to maintain that.

Change-Id: Idcf2f5acd4ca7070ce18d7149cbfc0d967dc0a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5632
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'third_party/nix/src/CMakeLists.txt')
-rw-r--r--third_party/nix/src/CMakeLists.txt85
1 files changed, 0 insertions, 85 deletions
diff --git a/third_party/nix/src/CMakeLists.txt b/third_party/nix/src/CMakeLists.txt
deleted file mode 100644
index 486c69fa2a..0000000000
--- a/third_party/nix/src/CMakeLists.txt
+++ /dev/null
@@ -1,85 +0,0 @@
-# -*- mode: cmake; -*-
-
-# The 'nix' binary is composed of various sources below this
-# directory. In the previous build system, they were all built from
-# this location and this setup mimics that (with the exception of the
-# various Nix libraries).
-
-add_subdirectory(proto)
-add_subdirectory(libutil)
-add_subdirectory(libstore)
-add_subdirectory(libmain)
-add_subdirectory(libexpr)
-add_subdirectory(nix-daemon)
-
-if (PACKAGE_TESTS)
-  add_subdirectory(tests)
-endif()
-
-add_executable(nix)
-set_property(TARGET nix PROPERTY CXX_STANDARD 17)
-include_directories(${PROJECT_BINARY_DIR})
-target_include_directories(nix PUBLIC "${nix_SOURCE_DIR}/src")
-
-target_sources(nix
-  PRIVATE
-    nix/command.hh
-    nix/legacy.hh
-    nix-env/user-env.hh
-    nix-store/dotgraph.hh
-    nix-store/graphml.hh
-
-    nix/add-to-store.cc
-    nix/build.cc
-    nix/cat.cc
-    nix/command.cc
-    nix/copy.cc
-    nix/doctor.cc
-    nix/dump-path.cc
-    nix/edit.cc
-    nix/eval.cc
-    nix/hash.cc
-    nix/installables.cc
-    nix/legacy.cc
-    nix/log.cc
-    nix/ls.cc
-    nix/main.cc
-    nix/optimise-store.cc
-    nix/path-info.cc
-    nix/ping-store.cc
-    nix/repl.cc
-    nix/run.cc
-    nix/search.cc
-    nix/show-config.cc
-    nix/show-derivation.cc
-    nix/sigs.cc
-    nix/upgrade-nix.cc
-    nix/verify.cc
-    nix/why-depends.cc
-
-    build-remote/build-remote.cc
-    nix-build/nix-build.cc
-    nix-channel/nix-channel.cc
-    nix-collect-garbage/nix-collect-garbage.cc
-    nix-copy-closure/nix-copy-closure.cc
-    nix-env/nix-env.cc
-    nix-env/user-env.cc
-    nix-instantiate/nix-instantiate.cc
-    nix-prefetch-url/nix-prefetch-url.cc
-    nix-store/dotgraph.cc
-    nix-store/graphml.cc
-    nix-store/nix-store.cc
-)
-
-target_link_libraries(nix
-  nixexpr
-  nixmain
-  nixstore
-  nixutil
-
-  absl::strings
-  editline
-  glog
-)
-
-INSTALL(TARGETS nix DESTINATION bin)