about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-25T01·03-0400
committerglittershark <grfn@gws.fyi>2020-07-25T02·29+0000
commit4dca023385034839873b330cb6fcaf46807e0a59 (patch)
tree49ef9c33c4d4eb43be912bba855611a87232b9f7 /third_party/nix/default.nix
parent6936ee40afa5b333c3396e1be48f3a4aab72cf07 (diff)
feat(3p/nix): Add build for VM for testing tvix r/1465
Add an expression, based on the nixos qemu virtualisation framework, for
a basic system whose nix is tvix, to be used for testing tvix

Change-Id: I3c7422bb10d3ce05a3094671cb770f1f745d814c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1423
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: Alyssa Ross <hi@alyssa.is>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/nix/default.nix')
-rw-r--r--third_party/nix/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index bc25689461..c8ed5adc87 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -1,4 +1,6 @@
-{ pkgs ? (import ../.. {}).third_party
+args@{
+  pkgs ? (import ../.. {}).third_party
+, lib
 , buildType ? "release"
 , depotPath ? ../..
 , ...
@@ -138,4 +140,6 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
 
   # TODO(tazjin): integration test setup?
   # TODO(tazjin): docs generation?
+
+  passthru = { test-vm = import ./test-vm.nix args; };
 }