about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T16·20+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T20·42+0000
commit739a45f9e47f35680117af61dc1a3aa2f5615636 (patch)
treeb5c9f1884bfbe033e5648f5557e06db6e26a472c /third_party/nix/CMakeLists.txt
parenta54f155c0715b42cdee0485200658075fb6cf173 (diff)
chore(3p/nix): use GNUInstallDirs to determine output directory names r/1051
This ensures that we install both glog's .a and all the .so files we
generate into a single consistent output lib path (which is, err,
lib64, but whatever).

Change-Id: Ib6ac6eacf5f56e4b719cfb586db731efc122c31b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/544
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 012a63bcb9..24de6824de 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -7,6 +7,9 @@ set(CMAKE_CXX_STANDARD 17)
 # clangd and clang-tidy.
 set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
 
+# Provide an output path for pkgconfig.
+include(GNUInstallDirs)
+
 # The following lines import CMake-native dependencies which may
 # contain useful definitions. Other dependencies are not treated
 # specially by CMake and are only linked into the resulting binary.