about summary refs log tree commit diff
path: root/third_party/lisp/prove.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·00+0300
committerclbot <clbot@tvl.fyi>2021-12-14T21·21+0000
commitb0614b5c83ae62672cb036bebb6ce12675aa3074 (patch)
treeac2a4fafa87dae3a0f452fb54977421db9a21344 /third_party/lisp/prove.nix
parent46a2c75a596b292d02d8647dfb44205dd876fd6f (diff)
refactor(3p/lisp): Move things from //users/wpcarro/third_party/lisp r/3245
* move packages and adapt them for the depot structure instead of
  briefcase
* drop linear-programming package, it didn't build anyways

Note that at least some of these packages (e.g. prove) are deprecated
upstream, but lets sort that out later.

Change-Id: I7f5a5faa29d57f060b21ac8e1706090866a82000
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4330
Autosubmit: tazjin <mail@tazj.in>
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/lisp/prove.nix')
-rw-r--r--third_party/lisp/prove.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/lisp/prove.nix b/third_party/lisp/prove.nix
new file mode 100644
index 0000000000..358049865e
--- /dev/null
+++ b/third_party/lisp/prove.nix
@@ -0,0 +1,34 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/fukamachi/prove.git";
+    rev = "5d71f02795b89e36f34e8c7d50e69b67ec6ca2de";
+    hash = "sha256:0ca6ha3zhmckq3ad9lxm6sbg4i0hg3m81xhan4dkxd3x9898jzpc";
+  };
+in depot.nix.buildLisp.library {
+  name = "prove";
+
+  deps = [
+    depot.third_party.lisp.alexandria
+    depot.third_party.lisp.cl-ansi-text
+    depot.third_party.lisp.cl-colors
+    depot.third_party.lisp.cl-ppcre
+    (depot.nix.buildLisp.bundled "asdf")
+  ];
+
+  srcs = [
+    "${src}/src/color.lisp"
+    "${src}/src/output.lisp"
+    "${src}/src/asdf.lisp"
+    "${src}/src/report.lisp"
+    "${src}/src/reporter.lisp"
+    "${src}/src/reporter/fiveam.lisp"
+    "${src}/src/reporter/list.lisp"
+    "${src}/src/reporter/dot.lisp"
+    "${src}/src/reporter/tap.lisp"
+    "${src}/src/suite.lisp"
+    "${src}/src/test.lisp"
+    "${src}/src/prove.lisp"
+  ];
+}