about summary refs log tree commit diff
path: root/third_party/lisp/parse-number.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-21T22·53-0400
committerglittershark <grfn@gws.fyi>2020-07-23T00·08+0000
commit08397fd7579c32a9a1d9bdd1b33abce9209f7c47 (patch)
treed831babe8fae1ef883d97ef4ffbf5db5a4a334c6 /third_party/lisp/parse-number.nix
parentef64479c9dbd590c50eee27b21596102024f8bc5 (diff)
feat(3p/lisp): Add many packages r/1420
Add the following packages along with their transitive dependencies:
- trivial-ldap
- defclass-std
- easy-routes

Change-Id: Ib24517f18d14d57540362132c9a24ff2a5a4bd9d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1336
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'third_party/lisp/parse-number.nix')
-rw-r--r--third_party/lisp/parse-number.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/lisp/parse-number.nix b/third_party/lisp/parse-number.nix
new file mode 100644
index 0000000000..1ceba2863d
--- /dev/null
+++ b/third_party/lisp/parse-number.nix
@@ -0,0 +1,17 @@
+{ depot, pkgs, ... }:
+
+let
+
+  src = pkgs.fetchFromGitHub {
+    owner = "sharplispers";
+    repo = "parse-number";
+    rev = "7707b224c4b941c2cbd28459113534242cee3a31";
+    sha256 = "0sk06ib1bhqv9y39vwnnw44vmbc4b0kvqm37xxmkxd4dwchq82d7";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "parse-number";
+  srcs = map (f: src + ("/" + f)) [
+    "parse-number.lisp"
+  ];
+}