about summary refs log tree commit diff
path: root/third_party/josh/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-02T14·37+0200
committertazjin <mail@tazj.in>2021-05-04T15·47+0000
commit47986fdc216ac03b8005416e4d646421ddd9e6ef (patch)
tree8c3677ecbb05f78b35ce2ddfad8873bba88563fc /third_party/josh/default.nix
parent790c0d938e2f99fe3af1d256730de861e3a7480e (diff)
chore(3p/josh): Bump version to latest HEAD r/2563
This lets us drop the patch for pinning the git library, as this one
is now pinned to something upstream.

Change-Id: Ib8026f5f22e2e49371a2bad83aa726c2951570e4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3086
Tested-by: BuildkiteCI
Reviewed-by: eta <eta@theta.eu.org>
Diffstat (limited to 'third_party/josh/default.nix')
-rw-r--r--third_party/josh/default.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/third_party/josh/default.nix b/third_party/josh/default.nix
index a7e4b30b8e..e82bf2df88 100644
--- a/third_party/josh/default.nix
+++ b/third_party/josh/default.nix
@@ -2,19 +2,11 @@
 { depot, pkgs, ... }:
 
 let
-  gitSrc = pkgs.fetchFromGitHub {
+  src = pkgs.fetchFromGitHub {
     owner = "esrlabs";
     repo = "josh";
-    rev = "1c1965deb0278de92452a597c092f16b531274ae";
-    sha256 = "0a0ybx4dqr9gfcn1kqy2nirdsfbdwkfz24ljnri564c5381ccldw";
-  };
-
-  src = pkgs.applyPatches {
-    name = "josh-src";
-    src = gitSrc;
-    patches = [
-      ./pin-git2-rev.patch
-    ];
+    rev = "92fd7fb193d0df25b106207675f233cfe1d26d0d";
+    sha256 = "0fzy9xbr0vnw239gl8famrqncn8pxlnwkfvy3gxl7c80d78yg9j7";
   };
 in depot.third_party.naersk.buildPackage {
   inherit src;