about summary refs log tree commit diff
path: root/third_party/haskell_overlay/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T01·27-0400
committerglittershark <grfn@gws.fyi>2020-06-29T01·56+0000
commit8091da8f0f6efd365dddf4a09555ed49c093ea50 (patch)
tree0c79b385807ba80de21a9fd2f09ec5cbb57067bc /third_party/haskell_overlay/default.nix
parent0ecc9b4ed3e53698dc44332abd06c67a6f8ffdbb (diff)
feat(3p/haskellPackages): port in patches from xanthous r/1124
Add a few relatively uncontroversial patches to fix some broken packages
that I had developed for xanthous to the top-level third_party tree, so
they can be reused by other people in the monorepo

Change-Id: I68740477bda278c5dcc123080029ee4bd2cae37a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/740
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/haskell_overlay/default.nix')
-rw-r--r--third_party/haskell_overlay/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/haskell_overlay/default.nix b/third_party/haskell_overlay/default.nix
new file mode 100644
index 0000000000..76e297173d
--- /dev/null
+++ b/third_party/haskell_overlay/default.nix
@@ -0,0 +1,34 @@
+{ pkgs ? import ./nixpkgs.nix {} }:
+
+self: super: with pkgs.haskell.lib; rec {
+  generic-arbitrary = appendPatch
+    super.generic-arbitrary
+    [ ./patches/generic-arbitrary-export-garbitrary.patch ];
+
+  hgeometry =
+    appendPatch
+      (self.callHackageDirect {
+        pkg = "hgeometry";
+        ver = "0.9.0.0";
+        sha256 = "02hyvbqm57lr47w90vdgl71cfbd6lvwpqdid9fcnmxkdjbq4kv6b";
+      } {}) [ ./patches/hgeometry-fix-haddock.patch ];
+
+  hgeometry-combinatorial =
+    self.callHackageDirect {
+      pkg = "hgeometry-combinatorial";
+      ver = "0.9.0.0";
+      sha256 = "12k41wd9fd1y3jd5djwcpwg2s1cva87wh14i0m1yn49zax9wl740";
+    } {};
+
+  vinyl = overrideSrc (markUnbroken super.vinyl)
+    rec {
+      src = pkgs.fetchzip {
+        url = "mirror://hackage/vinyl-${version}/vinyl-${version}.tar.gz";
+        sha256 = "190ffrmm76fh8fi9afkcda2vldf89y7dxj10434h28mbpq55kgsx";
+      };
+      version = "0.12.0";
+    };
+
+  comonad-extras = appendPatch (markUnbroken super.comonad-extras)
+    [ ./patches/update-comonad-extras.patch ];
+}