about summary refs log tree commit diff
path: root/third_party/haskell-language-server/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-03T15·51-0400
committerglittershark <grfn@gws.fyi>2020-07-03T23·23+0000
commit64ce8522fed750fcfb3a0504267f57dd20bcfb99 (patch)
tree5c8837966a080a4c45facfec074d6882432cd731 /third_party/haskell-language-server/default.nix
parent10180e70ec6bde46d307c4b50cfb23184f66ad2d (diff)
feat(3p): add haskell-language-server r/1203
Add expression for building haskell-language-server, based on a vendored
version of https://github.com/korayal/hls-nix with hashes updated to
work with our nixpkgs version and ghc 8.8.3. Also add that to CI
builds, so whitby will build it for me (thanks whitby).

Change-Id: I373f8a7cb67974b8aa043b116436c074591b8d57
Reviewed-on: https://cl.tvl.fyi/c/depot/+/897
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: BuildkiteCI
Diffstat (limited to 'third_party/haskell-language-server/default.nix')
-rw-r--r--third_party/haskell-language-server/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/third_party/haskell-language-server/default.nix b/third_party/haskell-language-server/default.nix
new file mode 100644
index 0000000000..82dcbaf82d
--- /dev/null
+++ b/third_party/haskell-language-server/default.nix
@@ -0,0 +1,6 @@
+{ pkgs, ... }:
+
+rec {
+  hls-nix = { ghc }: import ./hls.nix { inherit pkgs ghc; };
+  ghc883 = hls-nix { ghc = "ghc883"; };
+}